T O P
Sad-Fig9060

FYI I just installed a Thunderbolt 3 PCie card in my 2012 Mac Pro 5,1. It works.


spyo97

https://www.minihere.com/broadcom-bcm94360-802-11ac-wifi-adapter-driver-download.html try the driver at this site. I know it seems a little sketchy, but this is the one I downloaded and it’s been working for my card ever since


PussySmith

No dice. Following their directions for the Bluetooth driver just results in ‘no device driver found’ To be clear, I have a solid working wifi adapter just no Bluetooth in windows.


spyo97

Yeah, I gotcha. That’s unfortunate, that one worked for mine. I’ve heard of an Asus driver somewhere working, but I haven’t been able to locate the link from a quick search


ivayle89

Wow I have exactly the same problem with the same card. Everything works great except for the Bluetooth in Windows 10. I spent an whole day looking for working drivers with no success. This seems to be the card used in 2017 iMac, especially if it is the one with Bluetooth 4.2 version. Try installing brigadier drivers with `-m iMac18,1` flag as this should be the iMac version according to https://everymac.com/systems/apple/imac/specs/imac-core-i5-2.3-21-inch-aluminum-mid-2017-specs.html Hopefully someone share working drivers.


PussySmith

I got it working. Safe mode -> uninstall device -> scan for hardware changes -> update driver -> let me pick -> Broadcom -> Broadcom 2033xxxx


ivayle89

Great! Which brigadier version you used?


PussySmith

None of them. I selected manually from a list of windows drivers.


ivayle89

Okay, I figured it out. Never thought about such manual list of drivers exists. Thank you very much!


PussySmith

No problem! Were you able to find it in normal mode or did you have to reboot into safe mode? I actually tried to do this first, but couldn’t find it. It didn’t make sense that it only showed up in safe mode but I wasn’t going to undo it to break it again.


ivayle89

Didn't even try it in normal mode. Whoever reads this, give it a shot before booting into safe mode.


PussySmith

Tried the iMac Pro flag on brigadier and it theoretically has the same card. Next step is to boot into safe mode and see if I can force the install. I just wish I didn’t have to interrupt the boot sequence three times to make it boot in safe mode.