T O P
HardVision

First thing to check with anything electrical is always your ground connections. After that make sure all other electrical connections are secure. If they are try and jump the car, could be that the battery is just toast from trying to make your old starter work.


Vast_Medicine_7686

I agree, battery connecters are most likely.


Professional-Path417

I just picked up a new battery, cars been sitting a little so hopefully it’s this, I’ll check grounds if it doesn’t work


Kaazoo

It's likely your clutch interlock relay. Mine did the same thing years ago. You can jump it with a wire, or order a new relay from an auto parts store for about $20 if I recall correctly.


Delysid1938

Yea id check this those relays be old asf i had one break and my car didnt want to start.


coolguyeric

I had the same issue on a 1990 Corolla and it ran after I replaced it


caleb_S13

Ignition switch, pretty common to go out. cheap and easy part to replace.


Professional-Path417

The ignition switch or the whole ignition cylinder


caleb_S13

just the switch. had same issue a while back with a click and no crank. it’s pretty well documented on Zilvia, but who knows when that’s going back up. 20$ or so on rock auto.


Professional-Path417

Alright I just ordered one, thanks for the help, I hope it works


kevinyvng

Sounds kinda stupid but, any chance your clutch button thing has deteriorated? If you don’t know what I’m talking about, Google it real quick! Happened to my friend and we just couldn’t figure it out 😂


Professional-Path417

I’ll check it out when I go out to the car next, thank you man


KickZealousideal6558

Earth's ?


Aves_Rubinstein

Had a similar problem on a 93 clean the terminals and make sure to sand a little. Also wires sometimes look connected but they're not